Using certs

May 12, 2009 at 3:56 PM

I have installed my certs on the device.

When I run my app I get the following error:

The identity check failed for the outgoing message. The expected identity is (my cert name) for the (my ip address) target endpoint.

I have not been able to find anything that sheds any light on the issue.

Any ideas on some possibilities.

 

Thanks

 

Coordinator
May 13, 2009 at 2:34 PM

This error means that the service certificate (wcfmobile.com) does not match the domain (your machine name). You have to make sure that you configure your "hosts" file for self-hosted (console host) examples. I am assuming you may not have done this, or that you did not put the correct IP address in the hosts file. Please review the setup instructions again and let me know if you still have a problem.

Mar 24, 2010 at 5:26 PM

Hi, i have the same problem.

The windows mobile emulator is ignoring the host file of vista. Firstly i by passed the problem by using a small dns server, which resolves mobilewcf.com to the ip address of my server. This works fine.  But now i want to use a demo certificate with the identity "xwssecurityserver" provided by glassfish. Because of the missing domain in the identity, i can not set this identity as my endpoint address because the windows mobile emulator generates with such a url no request to the dns server and the connection failes.

As i understand this security mechanism, it compares the endpoint-address and the identity of the certificate. When they are not identically the exception is thrown. Is there a way to ignore this kind of check ?

I'm also wondering why a manipulation of the host file can have an effect on the emulated windows mobile, because windows mobile has his own network settings like the ip address or the dns server.

Thanks